動かざることバグの如し

殿、温めておいたバグがこちらでございます

MacOSをSierraにアップデートしたらbundle install nokogiriでコケる

久々にbundle installでコケた

$bundle
Fetching gem metadata from https://rubygems.org/..........
Fetching gem metadata from https://rubygems.org/.
Resolving dependencies...
Using rake 12.3.0
Using concurrent-ruby 1.0.5
Using i18n 0.9.1
Using minitest 5.10.3
Using thread_safe 0.3.6
Using tzinfo 1.2.4
Using activesupport 5.1.4
Using builder 3.2.3
Using erubi 1.7.0
Using mini_portile2 2.3.0
Fetching nokogiri 1.8.1
Installing nokogiri 1.8.1 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /Users/thr3a/.rbenv/versions/2.3.4/lib/ruby/gems/2.3.0/gems/nokogiri-1.8.1/ext/nokogiri
/Users/thr3a/.rbenv/versions/2.3.4/bin/ruby -r ./siteconf20171215-25720-z066a2.rb extconf.rb --use-system-libraries
checking if the C compiler accepts ... *** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of necessary
libraries and/or headers.  Check the mkmf.log file for more details.  You may
need configuration options.

Provided configuration options:
    --with-opt-dir
    --without-opt-dir
    --with-opt-include
    --without-opt-include=${opt-dir}/include
    --with-opt-lib
    --without-opt-lib=${opt-dir}/lib
    --with-make-prog
    --without-make-prog
    --srcdir=.
    --curdir
    --ruby=/Users/thr3a/.rbenv/versions/2.3.4/bin/$(RUBY_BASE_NAME)
    --help
    --clean

何もしてないのに・・・とか思ってたけど、よく考えたらMacOSSierraに上げたわ(

OSのアップデート後はコマンドライン開発ツールの更新をしなくてはいけないらしい。

xcode-select --install

した後に

brew install libxml2

すでにインストールしてあった場合はbrew uninstall libxml2して再インストール

これでいけた